基本配置
Router>enable //进入特权执行模式
Router#configure terminal  //进入全局配置模式
Router(config)#hostname R1 //将路由器名称配置为 R1
R1(config)#no ip domain-lookup //命令禁用 DNS
R1(config)#enable secret class //配置执行模式口令
//
R1(config)#line console 0
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#exit
R1(config)#line vty 0 4
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#exit
//
//
使用 IP 地址 192.168.1.1/24 配置 FastEthernet 0/0 接口
R1(config)#interface fastethernet 0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown
使用 IP 地址 192.168.2.1/24 配置 Serial0/0/0 接口
将时钟频率设置为 64000
R1(config-if)#interface serial 0/0/0
R1(config-if)#ip address 192.168.2.1 255.255.255.0
R1(config-if)#clock rate 64000
R1(config-if)#no shutdown
//
路由配置
//要使用指定的下一跳地址配置静态路由
R3 路由器上,配置通往 172.16.1.0 网络的静态路由(使用 R2 Serial 0/0/1 接口作为下一跳地址R3(config)#ip route 172.16.1.0 255.255.255.0 192.168.1.2
//使用送出接口配置静态路由
R3 路由器上,配置通往 172.16.2.0 网络的静态路由(使用 R3 路由器的 Serial 0/0/0 接口作为送出接口)R3(config)# ip route 172.16.2.0 255.255.255.0 Serial0/0/1
// R2 路由器上配置静态路由。
R2 路由器上,配置通往 null官方更新地址172.16.3.0 网络的静态路由(使用 R2 路由器的 Serial 0/0/0 接口作为送出接口)R2(config)# ip route 172.16.3.0 255.255.255.0 Serial0/0/0
//为 R1 路由器配置默认路由
R1 配置默认路由,使用 R1 Serial 0/0/0 接口作为下一跳接口。
R1(config)#ip route 0.0.0.0 0.0.0.0 172.16.2.2
// R3 路由器上配置总结静态路由
总结路由中将使用网络 172.16.0.0/22
R3(config)#ip route 172.16.0.0 255.255.252.0 192.168.1.2
/
/删除 R3 上的静态路由。
使用 no 形式的以下命令,将 R3 上当前配置的两条静态路由删除。
R3(config)#no ip route 172.16.1.0 255.255.255.0 192.168.1.2
R3(config)#no ip route 172.16.2.0 255.255.255.0 Serial0/0/0
基本RIP配置
//启用动态路由
R1(config)#router rip
//输入有类网络地址
R1(config-router)#network 192.168.1.0
//使用router rip network 命令在R2 路由器上配置 RIP
R2(config)#router rip
R2(config-router)#network 192.168.2.0
R2(config-router)#network 192.168.3.0
R2(config-router)#network 192.168.4.0
R2(config-router)#end
//可以使用 passive-interface fastethernet 0/0 命令禁止从该接口发送 RIPv1 更新。完成 RIP 配置后,返回特权执行模式并将当前配置保存到 NVRAM 中。
R1(config-router)#passive-interface fastethernet 0/0
R1(config-router)#end
//如下所示在 R2 上配置 RIP 路由
R2(config)#router rip
R2(config-router)#network 172.30.0.0
R2(config-router)#network 192.168.4.0
R2(config-router)#passive-interface fastethernet 0/0
R2(config-router)#end
// R2 配置为向 R1 发送默认静态路由信息
R2(config)#router rip
R2(config-router)#default-information originate
R2(config-router)#
基本OSPF配置
//在路由器 R1 上配置 OSPF
R1(config)#router ospf 1
R1(config-router)#
//一旦您处于 OSPF 配置子模式后,请将 LAN 172.16.1.16/28 配置为包括在从 R1 发出的 OSPF 更新中R1(config-router)#network 172.16.1.16 0.0.0.15 area 0
R1(config-router)#
//配置路由器,使其通告 Serial0/0/0 接口所连接的网络 192.168.10.0/30
R1(config-router)# network 192.168.10.0 0.0.0.3 area 0
R1(config-router)#
// R3 上使用router ospf network 命令配置 OSPF
R3(config)#router ospf 1
R3(config-router)#network 172.16.1.32 0.0.0.7 area 0
R3(config-router)#network 192.168.10.4 0.0.0.3 area 0
R3(config-router)#
//使用环回地址来更改拓扑中路由器的路由器 ID
R1(config)#interface loopback 0
R1(config-if)#ip address 10.1.1.1 255.255.255.255
R2(config)#interface loopback 0
R2(config-if)#ip address 10.2.2.2 255.255.255.255
R3(config)#interface loopback 0
R3(config-if)#ip address 10.3.3.3 255.255.255.255
//在路由器 R1 上使用router-id 命令更改路由器 ID
某些 IOS 版本不支持router-id 命令。如果无法使用此命令
R1(config)#router ospf 1
R1(config-router)#router-id 10.4.4.4
//在路由器 R1 R2 上使用 bandwidth 命令将串行接口的带宽更改为实际带宽 64 kbps
R1(config)#interface serial0/0/0
R1(config-if)#bandwidth 64
R1(config-if)#interface serial0/0/1
R1(config-if)#bandwidth 64
// 在路由器 R3 上使用ip ospf cost 命令配置 OSPF 开销
R3(config)#interface serial0/0/0
R3(config-if)#ip ospf cost 1562
R3(config-if)#interface serial0/0/1
R3(config-if)#ip ospf cost 1562
//在路由器 R1 上配置一个环回接口,以模拟通向 ISP 的链路
R1(config)#interface loopback1
R1(config-if)#ip address 172.30.1.1 255.255.255.252
//在路由器 R1 上配置一条静态默认路,使用已配置的用于模拟通向 ISP 的链路的环回地址作为出口接口
R1(config)#ip route 0.0.0.0 0.0.0.0 loopback1
R1(config)#
//使用default-information originate 命令将该静态路由包括在从路由器 R1 发出
OSPF 更新中
R1(config)#router ospf 1
R1(config-router)#default-information originate
R1(config-router)#
// 使用 OSPF 优先级确定 DR BDR
使用ip ospf priority 接口命令将路由器 R1 OSPF 优先级更改为 255
R1(config)#interface fastEthernet0/0
R1(config-if)#ip ospf priority 255
R1(config-if)#end
基本 VLAN配置
//启用 S2 S3 上的用户端口
S2(config)#interface range fa0/6, fa0/11, fa0/18
S2(config-if-range)#switchport mode access

版权声明:本站内容均来自互联网,仅供演示用,请勿用于商业和其他非法用途。如果侵犯了您的权益请与我们联系QQ:729038198,我们将在24小时内删除。