计算机管理课程实验 试题一
1.采用递归求解的方法,用倒序输出字符串系统;
用户输入字符串程序运行后,将倒序输出
举例如下
Sample Input: abcdef
Sample Output: fedcba
#include "stdafx.h"
void p() {
char c;
if((c=getchar()) != '\n') {
printf怎么加endl p();
}
printf("%c",c);
}
int main() {
printf("请输入一个字符串:");
p();
printf("\n");
return 0;
}
2.输入一行字符串,按如下规则加密:
如果是英文字母则大写变小写、小写变大写
对非英文字符保持不变。试写加密程序。
#include "stdafx.h"
int main() {
/* 定义一个字符变量ch; */
char ch;
printf( "input characters:" );
/* 当输入的字符不是回车的时候就继续循环; */
while( (ch = getchar() ) != '\n' ) {
if ( ch >= 'A' && ch <= 'Z' ) {
ch = ch - 'A' + 'a';
} else if ( ch >= 'a' && ch <= 'z' ) {
ch = ch - 'a' + 'A';
}
/* 输出转换后的字符; */
putchar( ch );
}
}
3.设计一个学生的学习系统,
例如某学习小组有4位同学,学习五门课程求每个同学的平均分。
举例如下:
姓名 | 课程1 | 课程2 | 课程3 | 课程4 | 课程5 | 平均分 |
赵彬 | 80 | 82 | 91 | 68 | 77 | |
张强 | 78 | 83 | 82 | 72 | 80 | |
张帅 | 73 | 58 | 62 | 60 | 75 | |
李莉 | 82 | 87 | 89 | 79 | 81 | |
#include "stdafx.h"
struct STU
{
char name[20];
int scores[5];
};
void OutputSTU(struct STU stu){
int total=0;
double avg;
int *scores = stu.scores;
for(int i=0;i<5;i++){
total+=scores[i];
}
avg=total/5.0;
printf("%s\t%d\t%d\t%d\t%d\t%d\t%lf\n", stu.name,scores[0],scores[1],scores[2],scores[3],scores[4],avg);
}
int main ()
{
printf("姓名\t课程1\t课程2\t课程3\t课程4\t课程5\t平均分\n");
struct STU students[4] = {
{"赵彬",{80,82,91,68,77}},
{"张强",{78,83,82,72,80}},
{"张帅",{73,58,62,60,75}},
{"李莉",{82,87,89,79,81}}
};
for(int i=0;i<4;i++){
struct STU stu = students[i];
OutputSTU(stu);
}
return 0;
}
计算机管理课程实验 试题三
1.简单加密系统。对字符按如下规则加密:如果英文字母则大写变小写、小写变大写
并且a->c、b->d 、···、x->z、y->a、z->b;对非英文字母保持不变。试写加密程序。
#include "stdafx.h"
char encode(char c) {
if(c=='y' || c=='Y' || c=='z' || c=='Z') {
c-=24;
} else if(c>='a'&&c<='z' || c>='A'&&c<='Z') {
c+=2;
}
if(c>='a'&&c<='z') {
c-=32;
} else if(c>='A'&&c<='Z') {
c+=32;
}
return c;
}
int main() {
char c;
printf("请输入一个字符串:\n");
while((c=getchar()) != '\n') {
printf("%c", encode(c));
}
printf("\n");
return 0;
}
2.简单排序系统,键盘输入N个战士的身高,用比较法将其升序排序。
#include "stdafx.h"
//总结:
// 1,总结思路,冒泡是目标值一直在移动,选择法是目标值固定但一直在比较
// 2,到i和j 的关系
// 3,比较完大小,记得交换值
int main() {
int a[10],i=0,temp,j;
printf("请输入一列数字,程序会为您按从大到小进行排序\n");
for (i=0;i<10;i++) {
scanf("%d",&a[i]);
}
for (i=0;i<10;i++) {
for (j=1;j<10-i;j++) {
if (a[i]>a[i+j]) {
temp=a[i+j];
a[i+j]=a[i];
a[i]=temp;
}
}
}
printf("排序结果\n");
for (i=0;i<10;i++) {
printf("%d ",a[i]);
}
}
3.编写一个C程序,分解出6378的每一个位数
#include "stdafx.h"
int main() {
int x=6378;
int a,b,c,d;
a=x%10000/1000;
/*分解出千位*/
b=x%1000/100;
/*分解出百位*/
c=x%100/10;
/*分解出十位*/
d=x%10;
/*分解出个位*/
printf("千位:%d\n", a);
printf("百位:%d\n", b);
printf("十位:%d\n", c);
printf("个位:%d\n", d);
}
管理信息系统(加考) 试题一
1.用数组的方法输出斐波那契数列 1,2,3,5,8,13,21,34,55,89,.......
写C程序,输出该数列的前N项
#include "stdafx.h"
int main() {
printf("请输入N的值(n<=100) 将列出前N项斐波那契数列的值:\n");
int n,i;
int arr[100]={1,2};
scanf("%d", &n);
for(i=2;i<n;i++){
arr[i]=arr[i-1]+arr[i-2];
}
for(i=0;i<n;i++){
printf("%d\n", arr[i]);
}
}
2.迭代法求某正数a的平方根。已知求平方根的迭代公式为:x1=1/2(x0+a/x0)。
#include "stdafx.h"
#include "math.h"
int main() {
printf("请输入N的值 将求出前N平方根:\n");
double n,x1,x2;
scanf("%lf", &n);
x2=1.0;
while(true){
x1=x2;
x2=(x1+n/x1)/2.0;
if (fabs(x1-x2)<0.00001){
printf("%.3f", x2);
break;
}
}
return 0;
}
3.简易口令程序系统。用户进入某系统,从键盘回答口令有3次机会。3次中任何一次回答正确均可进入系统
(显示“You are welcome! ”),否则不能进入系统(显示“I am sorry” )。试写C程序。
#include "stdafx.h"
#include "string.h"
int main() {
printf("欢迎登录 XX银行管理系统! 请输入您的登录密码(123456)\n");
printf("password:\n");
int time = 3;
char pass[100];
while(time>0){
scanf("%s", &pass);
if (strcmp(pass, "123456") == 0){
break;
}else{
time--;
printf("Password is worong. You have %d time to retry.\n", time);
}
}
if(time > 0){
printf("You are welcome! \n");
}else{
printf("I am sorry \n");
}
return 0;
}
管理信息系统(加考) 试题?
1.求圆的面积的简易系统。键盘输入圆的半径,求它的面积。本例要求通过指针变量访问实型变量。
#include "stdafx.h"
#include "iostream.h"
int main() {
版权声明:本站内容均来自互联网,仅供演示用,请勿用于商业和其他非法用途。如果侵犯了您的权益请与我们联系QQ:729038198,我们将在24小时内删除。
发表评论