//////////////////////////////////////////////
The Mailboxes Manufacturers Problem
Description
In the good old days when Swedish children were still allowed to blowup their fingers with fire-crackers, gangs of excited kids would plague certain smaller cities during Easter time, with only one thing in mind: To blow things up. Small boxes were easy to blow up, and thus mailboxes became a popular target. Now, a small mailbox manufacturer is interested in how many fire-crackers his new mailbox prototype can withstand without exploding and has hired you to help him. He will provide you with k (1 ≤ k ≤ 10) identical mailbox prototypes each fitting up to m (1 ≤ m ≤ 100) crackers. However, he is not sure of how many firecrackers he needs to provide you with in order for you to be able to solve his problem, so he asks you. You think for a while and then say, “Well,if I blow up a mailbox I can’t use it again, so if you would provide me with only k = 1 mailboxes, I would have to start testing with 1 cracker, then 2 crackers, and so on until it finally exploded. In the worst case, that is if it does not blow up eprintf怎么读英语
ven when filled with m crackers, I would need 1 + 2 + 3 + … + m = m × (m + 1) ⁄ 2 crackers. If m = 100 that would mean more than 5000 fire-crackers!” “That’s too many,” he replies. “What if I give you more than k = 1 mailboxes? Can you find a strategy that requires less crackers?”
Can you? And what is the minimum number of crackers that you should ask him to provide you with?
You may assume the following:
1. If a mailbox can withstand x fire-crackers, it can also withstand x − 1 fire-crackers.
2. Upon an explosion, a mailbox is either totally destroyed (blown up) or unharmed, which means that it can be reused in another test explosion.
Note: If the mailbox can withstand a full load of m fire-crackers, then the manufacturer will of course be satisfied with that answer. But otherwise he is looking for the maximum number of crackers that his mailboxes can withstand.
Input
The input starts with a single integer N (1 ≤ N ≤ 10) indicating the number of test cases to follow. Each test case is described by a line containing two integers: k and m, separated by a single space.
Output
For each test case print one line with a single integer indicating the minimum number of fire-crackers that is needed, in the worst case, in order to figure out how many crackers the mailbox prototype can withstand.
Sample Input
4
1 10
1 100
3 73
5 100
Sample Output
55
5050
382
495
Source
Svenskt Mästerskap i Programmering/Norgesmesterskapet 2002
#include <iostream>
using namespace std;
const int INF = 1 << 28;
int d[11][101][101];
int sum(int i, int j) {
    int ret = 0, k;
    for (k=i; k<=j; k++) ret += k;
    return ret;
}
int max(int a, int b) {
    return a > b ? a : b;
}
int main() {
    int caseTime; 
    int i, j, k, t, K, M, l;
    scanf("%d", &caseTime);
    while (caseTime--) {
        scanf("%d%d", &K, &M);
        for (i=1; i<=M; i++) {
            for (j=i; j<=M; j++) {
                d[1][i][j] = sum(i, j);
            }
        }
        for (k=2; k<=K; k++) {
            for (l=0; l<M; l++) {
                for (i=1; i+l<=M; i++) {
                    j = i + l;
                    if (i == j) {
                        d[k][i][j] = i;
                        continue;
                    }
                    d[k][i][j] = INF;
                    for (t=i; t<=j; t++) {
                        int tmp;
                        if (t == i) tmp = d[k][i+1][j];
                        else if (t == j) tmp = d[k-1][i][j-1];
                        else tmp = max(d[k-1][i][t-1], d[k-1][t+1][j]);
                        tmp = max(d[k-1][i][t-1], d[k][t+1][j]);
                        if (d[k][i][j] > t + tmp) d[k][i][j] = t + tmp;
                    }
                }
            }
        }
        printf("%d\n", d[K][1][M]);
    }
    return 0;
}
Bugs Integrated, Inc.
Description
Bugs Integrated, Inc. is a major manufacturer of advanced memory chips. They are launching production of a new six terabyte Q-RAM chip. Each chip consists of six unit squares arranged in a form of a 2*3 rectangle. The way Q-RAM chips are made is such that one takes a rectangular plate of silicon divided into N*M unit squares. Then all squares are tested carefully and the bad ones are marked with a black marker.

Finally, the plate of silicon is cut into memory chips. Each chip consists of 2*3 (or 3*2) unit squares. Of course, no chip can contain any bad (marked) squares. It might not be possible to cut the plate so that every good unit square is a part of some memory chip. The corporation wants to waste as little good squares as possible. Therefore they would like to know how to cut the plate to make the maximum number of chips possible.
Task
You are given the dimensions of several silicon plates and a list of all bad unit squares for each plate. Your task is to write a program that computes for each plate the maximum number of chips that can be cut out of the plate.
Input
The first line of the input file consists of a single integer D (1 <= D <= 5), denoting the number of silicon plates. D blocks follow, each describing one silicon plate. The first line of each block contains three integers N (1 <= N <= 150), M (1 <= M <= 10), K (0 <= K <= MN) separated by single spaces. N is the length of the plate, M is its height and K is the number of bad squares in the plate. The following K lines contain a list of bad squares. Each line consists of two integers x and y (1 <= x <= N, 1 <= y <= M) ?coordinates of one bad square (the upper left square has coordinates [1, 1], the bottom right is [N,M]).
Output
For each plate in the input file output a single line containing the maximum number of memory chips that can be cut out of the plate.
Sample Input
2
6 6 5
1 4
4 6
2 2
3 6

版权声明:本站内容均来自互联网,仅供演示用,请勿用于商业和其他非法用途。如果侵犯了您的权益请与我们联系QQ:729038198,我们将在24小时内删除。